<!DOCTYPE html>
<html class="no-js fullbg" lang="en-US">
<head>
<meta charset="UTF-8">
<title>Saints looking to catch Lane in the standings - The Advocate Online</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://www.advocate-online.net/xmlrpc.php" />
<link rel="stylesheet" href="http://www.advocate-online.net/wp-content/plugins/organize-series/orgSeries.css" type="text/css" media="screen" />
<!-- This site is optimized with the Yoast SEO plugin v4.7 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.advocate-online.net/sports/saints-looking-catch-lane-standings-13589/" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Mt. Hood squared off against Linn-Benton last Saturday and if you like offensive games, there was quite a leadoff game for you: extra innings, 11 innings, to be exact. It was an interesting one, for sure, with a total of 28 hits between both ballclubs, and pitching almost nonexistent, before the Roadrunners finally edged the Saints, 9-8. The Saints’ hitting was impressive and kept up with the standard of how they have been performing at the plate all year. Mt. Hood batters collected 12 hits and scored eight runs. But Linn-Benton hacked away at the plate, too, and tallied an impressive 16 hits. Of those 16 hits, two came in the clutch, in the top of the 11th inning. Logan Meadows led off with a double. Then came a crucial error by Saints third baseman Dru Fitz that allowed Meadows to advance to third and batter Alex O Rourke to make it to first. Spencer DesBiens then singled to bring in Meadows with the go-ahead run for the Roadrunners. Saints reliever Ian Turner then got the last two outs, but the damage was done. Batting last at the scheduled doubleheader, played at Columbia River High School in Vancouver, Mt. Hood [...]" />
<meta name="twitter:title" content="Saints looking to catch Lane in the standings - The Advocate Online" />
<meta name="twitter:site" content="@mhccadvocate" />
<meta name="twitter:image" content="http://www.advocate-online.net/wp-content/uploads/2017/05/saintstrendcolor.png" />
<meta name="twitter:creator" content="@mhccadvocate" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Advocate Online &raquo; Feed" href="http://www.advocate-online.net/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Advocate Online &raquo; Comments Feed" href="http://www.advocate-online.net/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Advocate Online &raquo; Saints looking to catch Lane in the standings Comments Feed" href="http://www.advocate-online.net/sports/saints-looking-catch-lane-standings-13589/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.advocate-online.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.5"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='jquery_ui_all-css'  href='http://www.advocate-online.net/wp-content/plugins/x-calender/css/jquery-ui.min.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='jquery_ui_base-css'  href='http://www.advocate-online.net/wp-content/plugins/x-calender/css/jquery-ui.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='wa-jquery-ui-multiselect-widget-css'  href='http://www.advocate-online.net/wp-content/plugins/x-calender/css/multi-select.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-ui-timepicker-css'  href='http://www.advocate-online.net/wp-content/plugins/x-calender/css/jquery.ui.timepicker.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='jquery_ui_datepicker-css'  href='http://www.advocate-online.net/wp-content/plugins/x-calender/css/jquery.ui.datepicker.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='wa-colour-picker-css'  href='http://www.advocate-online.net/wp-content/plugins/x-calender/css/colorpicker.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.advocate-online.net/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='youtube-channel-css'  href='http://www.advocate-online.net/wp-content/plugins/youtube-channel/assets/css/youtube-channel.min.css?ver=3.0.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-au-css'  href='http://www.advocate-online.net/wp-content/plugins/youtube-channel/assets/lib/magnific-popup/magnific-popup.min.css?ver=3.0.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='tt-easy-google-fonts-css'  href='http://fonts.googleapis.com/css?family=Crimson+Text%3Aregular%7CRoboto+Slab%3Aregular%7CCabin+Condensed%3Aregular&#038;subset=latin%2Clatin%2Call&#038;ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='kamn-css-easy-twitter-feed-widget-css'  href='http://www.advocate-online.net/wp-content/plugins/easy-twitter-feed-widget/easy-twitter-feed-widget.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='mh-purity-parent-style-css'  href='http://www.advocate-online.net/wp-content/themes/mh_purity/style.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='mh-purity-child-style-css'  href='http://www.advocate-online.net/wp-content/themes/mh_purity_child/style.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='mh-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lato:300italic,300,400italic,400,900|Vollkorn:400,400italic' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mh-style-css'  href='http://www.advocate-online.net/wp-content/themes/mh_purity_child/style.css?ver=v1.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='tabber_widget-tabber-widget-rounded-light-css'  href='http://www.advocate-online.net/wp-content/plugins/tabber-widget/templates/rounded-light.css?ver=4.6.5' type='text/css' media='all' />
<link rel='stylesheet' id='A2A_SHARE_SAVE-css'  href='http://www.advocate-online.net/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.9' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.1.7 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	var disableStr = 'ga-disable-UA-63529340-1';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-63529340-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 8]>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/json2.min.js?ver=2015-05-03'></script>
<![endif]-->
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.position.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.core.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.widget.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.tooltip.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.datepicker.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.dialog.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.effect.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/jquery/ui/jquery.ui.button.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/x-calender/js/jquery.ui.timepicker.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/x-calender/js/jquery-ui.multidatespicker.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/x-calender/js/jquery.multi-select.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/x-calender/js/colorpicker.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/themes/mh_purity/js/scripts.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/tabber-widget/js/jquery.idTabs.min.js?ver=4.6.5'></script>
<link rel='https://api.w.org/' href='http://www.advocate-online.net/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.advocate-online.net/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.advocate-online.net/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.6.5" />
<link rel='shortlink' href='http://www.advocate-online.net/?p=13589' />
<link rel="alternate" type="application/json+oembed" href="http://www.advocate-online.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.advocate-online.net/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F&#038;format=xml" />

<script type="text/javascript"><!--
var a2a_config=a2a_config||{},wpa2a={done:false,html_done:false,script_ready:false,script_load:function(){var a=document.createElement('script'),s=document.getElementsByTagName('script')[0];a.type='text/javascript';a.async=true;a.src='http://static.addtoany.com/menu/page.js';s.parentNode.insertBefore(a,s);wpa2a.script_load=function(){};},script_onready:function(){if(a2a.type=='page'){wpa2a.script_ready=true;if(wpa2a.html_done)wpa2a.init();}},init:function(){for(var i=0,el,target,targets=wpa2a.targets,length=targets.length;i<length;i++){el=document.getElementById('wpa2a_'+(i+1));target=targets[i];a2a_config.linkname=target.title;a2a_config.linkurl=target.url;if(el){a2a.init('page',{target:el});el.id='';}wpa2a.done=true;}wpa2a.targets=[];}};a2a_config.callbacks=a2a_config.callbacks||[];a2a_config.callbacks.push({ready:wpa2a.script_onready});
//--></script>
<style type="text/css">
ul.scfw_16px li, ul.scfw_24px li, ul.scfw_32px li, ul.scfw_16px li a, ul.scfw_24px li a, ul.scfw_32px li a {
	display:inline !important;
	float:none !important;
	border:0 !important;
	background:transparent none !important;
	margin:0 !important;
	padding:0 !important;
}
ul.scfw_16px li {
	margin:0 2px 0 0 !important;
}
ul.scfw_24px li {
	margin:0 3px 0 0 !important;
}
ul.scfw_32px li {
	margin:0 5px 0 0 !important;
}
ul.scfw_text_img li:before, ul.scfw_16px li:before, ul.scfw_24px li:before, ul.scfw_32px li:before {
	content:none !important;
}
.scfw img {
	float:none !important;
}
</style>	
	<!--[if lt IE 9]>
<script src="http://www.advocate-online.net/wp-content/themes/mh_purity/js/css3-mediaqueries.js"></script>
<![endif]-->
    <style type="text/css">
    	    	    		.header-wrap, .main-nav ul .current-menu-item > a, footer, .author-box, blockquote, .commentlist .bypostauthor, input[type=text]:hover, input[type=email]:hover, textarea:hover { border-color: #cc5d35; }
			.widget-title, .widget-title a, [id*='slider-'] .flex-direction-nav a, .fa-comment-o, .fa-circle, .breadcrumb .separator { color: #cc5d35 }
    	    	    			    		.entry a { color: #4a5777; }
    	    	    		a:hover, .post-nav a:hover, .breadcrumb a:hover, .post-meta a:hover, .post-tags a:hover { color: #cc3600; }
    			.flexslider {
    height: 440px;
    transition: all 1s ease 0s;
    background-color: #fff;
}
.flex-viewport {
    max-height: 440px;
    transition: all 1s ease 0s;
}
	</style>
    <link rel="icon" href="http://www.advocate-online.net/wp-content/uploads/2016/10/cropped-closeup-a-32x32.png" sizes="32x32" />
<link rel="icon" href="http://www.advocate-online.net/wp-content/uploads/2016/10/cropped-closeup-a-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.advocate-online.net/wp-content/uploads/2016/10/cropped-closeup-a-180x180.png" />
<meta name="msapplication-TileImage" content="http://www.advocate-online.net/wp-content/uploads/2016/10/cropped-closeup-a-270x270.png" />
			
							<style id="tt-easy-google-font-styles" type="text/css">
			
																						p {
							color: #0c0c0c; font-family: 'Crimson Text'; font-style: normal; font-weight: 400; text-decoration: none; text-transform: none; 						}
								
																										h1 {
							color: #000000; font-family: 'Roboto Slab'; font-style: normal; font-weight: 400; letter-spacing: 1px; text-decoration: none; text-transform: none; 						}
								
																										h2 {
							color: #000000; font-family: 'Cabin Condensed'; font-style: normal; font-weight: 400; text-decoration: none; text-transform: uppercase; 						}
								
																										h3 {
							color: #000000; font-family: 'Cabin Condensed'; font-style: normal; font-weight: 400; text-decoration: none; text-transform: uppercase; 						}
								
																										h4 {
							color: #000000; font-family: 'Cabin Condensed'; font-style: normal; font-weight: 400; text-decoration: none; 						}
								
																										h5 {
							color: #000000; font-family: 'Cabin Condensed'; font-style: normal; font-weight: 400; 						}
								
																										h6 {
							font-family: 'Cabin Condensed'; font-style: normal; font-weight: 400; 						}
								
										
							</style>
						</head>
<body class="single single-post postid-13589 single-format-standard">
<div class="container">
<header class="header-wrap">
	<div class="header-search"><form role="search" method="get" id="searchform" action="http://www.advocate-online.net/">
    <fieldset>
	<input type="text" value="" name="s" id="s" />
	<input type="submit" id="searchsubmit" value="Search" />
    </fieldset>
</form></div>
	<a href="http://www.advocate-online.net/" title="The Advocate Online" rel="home">
<div class="logo-wrap" role="banner">
<img class="header-image" src="http://www.advocate-online.net/wp-content/uploads/2016/10/logo2.png" height="94" width="453" alt="The Advocate Online" />
</div>
</a>
	<nav class="main-nav clearfix">
		<div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-9286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-9286"><a href="http://www.advocate-online.net/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-13499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13499"><a href="http://www.advocate-online.net/ongoing-series/">Ongoing Series</a></li>
</ul>
</li>
<li id="menu-item-9291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-9291"><a>Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-9290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9290"><a href="http://www.advocate-online.net/opinion/editorial/">Editorial</a></li>
	<li id="menu-item-9289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9289"><a href="http://www.advocate-online.net/opinion/column-opinion/">Column</a></li>
	<li id="menu-item-9364" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9364"><a href="http://www.advocate-online.net/opinion/letterfromeditor/">Letter from the Editor</a></li>
</ul>
</li>
<li id="menu-item-9287" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9287"><a href="http://www.advocate-online.net/sports/">Sports</a></li>
<li id="menu-item-9288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9288"><a href="http://www.advocate-online.net/lifestyle/">Arts + Entertainment</a></li>
<li id="menu-item-9284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9284"><a href="http://www.advocate-online.net/videos/">Videos</a></li>
<li id="menu-item-9282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9282"><a href="http://www.advocate-online.net/staff/">Staff</a></li>
<li id="menu-item-9283" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9283"><a href="http://www.advocate-online.net/venture/">Venture</a></li>
<li id="menu-item-9279" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-9279"><a href="http://www.advocate-online.net/contact/">Contact</a>
<ul class="sub-menu">
	<li id="menu-item-9277" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9277"><a href="http://www.advocate-online.net/advertising/">Advertising</a></li>
</ul>
</li>
</ul></div>	</nav>
</header><div class="wrapper clearfix">
	<div class="content left"><nav class="breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.advocate-online.net" itemprop="url"><span itemprop="title">Home</span></a></span> <span class="separator">&raquo;</span> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="http://www.advocate-online.net/sports/" itemprop="url"><span itemprop="title">Sports</span></a></span> <span class="separator">&raquo;</span> Saints looking to catch Lane in the standings</nav>
<article class="post-13589 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-featured reporter-logan-hertner">
	<header class="post-header">
		<h1 class="entry-title">Saints looking to catch Lane in the standings</h1>
		<p class="meta post-meta clearfix"><span class="updated meta-date"><i class="fa fa-calendar"></i>May 4, 2017</span><span class="vcard author meta-author"><span class="fn"><i class="fa fa-user"></i><a href="http://www.advocate-online.net/staff/logan-hertner/" rel="tag">Logan Hertner</a></span></span><span class="meta-tags"><i class="fa fa-tag"></i><a href="http://www.advocate-online.net/sports/" rel="category tag">Sports</a></span><span class="meta-comments"><i class="fa fa-comment-o"></i>0</span>
</p>
	</header>
		<div class="entry clearfix">
				<p>Mt. Hood squared off against Linn-Benton last Saturday and if you like offensive games, there was quite a leadoff game for you: extra innings, 11 innings, to be exact.</p>
<p>It was an interesting one, for sure, with a total of 28 hits between both ballclubs, and pitching almost nonexistent, before the Roadrunners finally edged the Saints, 9-8.</p>
<p>The Saints’ hitting was impressive and kept up with the standard of how they have been performing at the plate all year. Mt. Hood batters collected 12 hits and scored eight runs.</p>
<p>But Linn-Benton hacked away at the plate, too, and tallied an impressive 16 hits.</p>
<p>Of those 16 hits, two came in the clutch, in the top of the 11th inning. Logan Meadows led off with a double. Then came a crucial error by Saints third baseman Dru Fitz that allowed Meadows to advance to third and batter Alex O Rourke to make it to first.</p>
<p>Spencer DesBiens then singled to bring in Meadows with the go-ahead run for the Roadrunners.</p>
<p>Saints reliever Ian Turner then got the last two outs, but the damage was done.</p>
<p>Batting last at the scheduled doubleheader, played at Columbia River High School in Vancouver, Mt. Hood had a chance to tie or win in the bottom of the 11th.</p>
<p>After Linn-Benton pitcher Tanner Galey retired the first two batters with strikeouts, he hit Saints batter Jason Garcia with a pitch, then did the same to Saints hitter Hunter Crenshaw just four pitches later.</p>
<p>Now things were getting interesting with runners on first and second for the Saints and two outs. But Mt. Hood’s Travis Copher struck out swinging, not able to connect and make some magic happen.</p>
<p>You would think 12 hits and eight runs would be enough to get a victory, but that wasn’t the case in this crazy game.</p>
<p>The second game was no less wild. Trailing 5-0, the Saints rallied for six runs in the bottom of the fifth inning, before Linn-Benton scored one in the sixth for a 6-6 tie.</p>
<p>That’s when the game was suspended, due to darkness. The two teams will resume play in the seventh inning on Wednesday in Gresham, said Saints head coach Bryan Donohue.</p>
<p>The conclusion with Linn-Benton could be critical, since the Saints (11-18 overall) are in third place in the South Region, at 8-7, and in the playoff hunt.</p>
<p>First, the Saints look to gain ground with a doubleheader today at Lane Community College against the Titans, who are second in the South at 11-5. The first game is at 2 p.m. and the second starts at 5 p.m.</p>
<div id="crp_related" class="crp_related"><h3>Related Posts:</h3><ul><li><a href="http://www.advocate-online.net/sports/saints-on-hot-streak-after-sweeping-lakers-twice-13495/"     class="crp_title">Saints on hot streak after sweeping lakers twice</a></li><li><a href="http://www.advocate-online.net/sports/saints-atop-south-region-following-split-with-everett-8950/"     class="crp_title">Saints atop South Region following split with Everett</a></li><li><a href="http://www.advocate-online.net/sports/saints-in-first-following-sweep-of-clackamas-cc-8571/"     class="crp_title">Saints in first following sweep of Clackamas CC</a></li></ul><div class="crp_clear"></div></div><div class="addtoany_share_save_container addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list a2a_target" id="wpa2a_1"><a href="http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F&amp;linkname=Saints%20looking%20to%20catch%20Lane%20in%20the%20standings" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/facebook?linkurl=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F&amp;linkname=Saints%20looking%20to%20catch%20Lane%20in%20the%20standings', '');" class="a2a_button_facebook"  title="Facebook" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F&amp;linkname=Saints%20looking%20to%20catch%20Lane%20in%20the%20standings" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/twitter?linkurl=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F&amp;linkname=Saints%20looking%20to%20catch%20Lane%20in%20the%20standings', '');" class="a2a_button_twitter"  title="Twitter" rel="nofollow" target="_blank"></a><a href="http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F&amp;linkname=Saints%20looking%20to%20catch%20Lane%20in%20the%20standings" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.addtoany.com/add_to/google_plus?linkurl=http%3A%2F%2Fwww.advocate-online.net%2Fsports%2Fsaints-looking-catch-lane-standings-13589%2F&amp;linkname=Saints%20looking%20to%20catch%20Lane%20in%20the%20standings', '');" class="a2a_button_google_plus"  title="Google+" rel="nofollow" target="_blank"></a><a href="https://www.addtoany.com/share_save" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.addtoany.com/share_save', '');" class="a2a_dd addtoany_share_save"></a>
<script type="text/javascript"><!--
wpa2a.script_load();
//--></script>
</div></div>	</div>
			<div class="post-tags meta clearfix">
        	<p class="meta-tags"><i class="fa fa-tag"></i><a href="http://www.advocate-online.net/tag/featured/" rel="tag">featured</a></p>        </div>
		</article><nav class="post-nav-wrap clearfix" role="navigation">
<div class="post-nav left">
<a href="http://www.advocate-online.net/sports/saints-lose-lead-slip-to-13-12-after-split-13515/" rel="prev">Saints lose lead, slip to 13-12 after split</a></div>
<div class="post-nav post-nav-next right">
</div>
</nav>
				<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/sports/saints-looking-catch-lane-standings-13589/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.advocate-online.net/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><br/><textarea id="comment" name="comment" cols="45" rows="5" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name </label><span class="required">*</span><br/><input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email </label><span class="required">*</span><br/><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><br/><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='13589' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2d7827eb99" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="66"/></p><p style="clear:both"><input style="width: 20px" type="checkbox" value="1" name="subscribe" id="subscribe" checked="checked"/>&nbsp;<label style="margin:0; padding:0; position:relative; left:0; top:0;" for="subscribe">Notify me when new comments are added.</label></p>				</form>
					</div><!-- #respond -->
			</div>
	<aside class="sidebar sb-right">
	<div class="sb-widget"><h4 class="widget-title">Subscribe</h4><ul class="scfw_32px" style="list-style:none;margin:0;padding:0;"><li><a href="http://MHCCAdvocate" title="YouTube Channel"><img src="http://www.advocate-online.net/wp-content/plugins/subscribe-connect-follow-widget/images/32px/youtube.png" alt="YouTube" height="32px" width="32px" /></a></li><li><a href="http://feeds.feedburner.com/advocate-online/" title="Subscribe to RSS Feed"><img src="http://www.advocate-online.net/wp-content/plugins/subscribe-connect-follow-widget/images/32px/rss.png" alt="RSS Feed" height="32px" width="32px" /></a></li><li><a href="https://www.facebook.com/TheAdvocateOnline" title="Connect on Facebook"><img src="http://www.advocate-online.net/wp-content/plugins/subscribe-connect-follow-widget/images/32px/facebook.png" alt="Facebook" height="32px" width="32px" /></a></li><li><a href="https://twitter.com/mhccadvocate" title="Follow mhccadvocate on Twitter"><img src="http://www.advocate-online.net/wp-content/plugins/subscribe-connect-follow-widget/images/32px/twitter.png" alt="Twitter" height="32px" width="32px" /></a></li><li><a href="http://instagram.com/MHCCadvocate" title="MHCCadvocate on Instagram"><img src="http://www.advocate-online.net/wp-content/plugins/subscribe-connect-follow-widget/images/32px/instagram.png" alt="Instagram" height="32px" width="32px" /></a></li></ul></div><div class="sb-widget"><h4 class="widget-title">Advertisements</h4>			<div class="textwidget"><a href="https://www.eou.edu/" target="_blank"><img class="alignright" src="http://www.advocate-online.net/wp-content/uploads/2016/10/EOU-web-ad.png" alt="EOU" width="310" height="172" /></a>
<p>
<a href="http://www.marylhurst.edu/mhcc" target="_blank"><img class="alignright size-full wp-image-11624" src="http://www.advocate-online.net/wp-content/uploads/2016/04/marylhurst-2016.gif" alt="Marylhurst" width="310" height="500" /></a>
</p><p>
</p></div>
		</div><div class="sb-widget"><h4 class="widget-title">Facebook</h4><div class="fb-page" data-href="https://www.facebook.com/TheAdvocateOnline" data-width="310" data-height="500" data-hide-cover="0" data-show-facepile="0" data-show-posts="1"></div>
</div><div class="sb-widget">		<div class="widget-easy-twitter-feed-widget-global-wrapper">
			<div class="widget-easy-twitter-feed-widget-container">

				<div class="row">
				  <div class="col-lg-12">
					<h4 class="widget-title"><span>Twitter</span></h4>				  </div>
				</div>

	          	<div class="widget-easy-twitter-feed-widget-row">
		          	<div class="widget-easy-twitter-feed-widget-col">
			          <div class="twitterwidget widget-easy-twitter-feed-widget-kamn-2">
						<a class="twitter-timeline" width="300" height="250" href="https://twitter.com/twitterdev" data-widget-id="344713329262084096" data-screen-name="MHCCadvocate" data-show-replies="false" data-theme="light" data-link-color="" data-border-color="" data-chrome="" data-tweet-limit="3">Tweets by @MHCCadvocate</a>
			          </div>
	          		</div>
          		</div>

          	</div> <!-- End .widget-global-wrapper -->
        </div>

</div><div class="sb-widget"><div class="youtube_channel default"><div class="ytc_video_container ytc_video_1 ytc_video_first ar16_9" style="width:306px"><a href="//www.youtube.com/watch?v=XDLT7BQZ9m8&amp;modestbranding=1" title="Mace Archer interview" class="ytc_thumb ytc-lightbox ar16_9"><span style="background-image: url(//img.youtube.com/vi/XDLT7BQZ9m8/0.jpg);" title="Watch video Mace Archer interview published on 2017-05-05T01:17:07.000Z" id="ytc_XDLT7BQZ9m8"></span></a><h3 class="ytc_title">Mace Archer interview</h3></div><!-- .ytc_video_container --><div class="ytc_video_container ytc_video_2 ytc_video_last ar16_9" style="width:306px"><a href="//www.youtube.com/watch?v=nV0fsGuYSD0&amp;modestbranding=1" title="Get to know MHCC's Funeral Service Program" class="ytc_thumb ytc-lightbox ar16_9"><span style="background-image: url(//img.youtube.com/vi/nV0fsGuYSD0/0.jpg);" title="Watch video Get to know MHCC's Funeral Service Program published on 2017-02-26T05:56:25.000Z" id="ytc_nV0fsGuYSD0"></span></a><h3 class="ytc_title">Get to know MHCC's Funeral Service Program</h3></div><!-- .ytc_video_container --></div><!-- .youtube_channel --><div class="clearfix"></div></div><div class="sb-widget"><h4 class="widget-title">Recent Comments</h4>        <ul class="user-widget row clearfix">				<li class="uw-wrap clearfix">					<div class="uw-text">Carey Mulligan on <a href="http://www.advocate-online.net/uncategorized/john-wick-chapter-2-brings-neo-noir-13101/#comment-26198" title="Carey Mulligan | &#8216;John Wick Chapter 2&#8217; brings &#8216;Neo Noir&#8217;">&#8216;John Wick Chapter 2&#8217; brings &#8216;Neo Noir&#8217;</a></div>
				</li>				<li class="uw-wrap clearfix">					<div class="uw-text">Advocate Staff on <a href="http://www.advocate-online.net/news/newsbrief/psu-transfer-workshop-to-be-held-in-jazz-cafe-6140/#comment-26057" title="Advocate Staff | PSU transfer workshop to be held in Jazz Café">PSU transfer workshop to be held in Jazz Café</a></div>
				</li>				<li class="uw-wrap clearfix">					<div class="uw-text">Joyce on <a href="http://www.advocate-online.net/news/newsbrief/psu-transfer-workshop-to-be-held-in-jazz-cafe-6140/#comment-26056" title="Joyce | PSU transfer workshop to be held in Jazz Café">PSU transfer workshop to be held in Jazz Café</a></div>
				</li>				<li class="uw-wrap clearfix">					<div class="uw-text">Jane S. on <a href="http://www.advocate-online.net/lifestyle/animation-supports-character-malleability-and-power-13437/#comment-25622" title="Jane S. | Animation supports character malleability and power">Animation supports character malleability and power</a></div>
				</li>				<li class="uw-wrap clearfix">					<div class="uw-text">Maria on <a href="http://www.advocate-online.net/news/mhcc-lgbtqai-community-can-find-support-with-gsa-8556/#comment-25336" title="Maria | MHCC LGBTQAI+ community can find support with GSA">MHCC LGBTQAI+ community can find support with GSA</a></div>
				</li>        </ul></div><div class="sb-widget">			<div class="textwidget"></div>
		</div><div class="sb-widget">			<div class="textwidget"></div>
		</div></aside></div>
<footer class="footer clearfix">
			<div class="col-1-3 footer-widget-area">
					<div class="footer-widget footer-1">		<h6 class="footer-widget-title">Recent Posts</h6>		<ul>
					<li>
				<a href="http://www.advocate-online.net/arts-entertainment/kehlani-headlines-crystal-ballroom-13670/">Kehlani headlines at the Crystal Ballroom</a>
						</li>
					<li>
				<a href="http://www.advocate-online.net/news/registration-fall-summer-term-now-open-students-13577/">Registration for Fall and Summer term is now open to all students</a>
						</li>
					<li>
				<a href="http://www.advocate-online.net/news/robotic-manufacturing-program-launch-fall-13604/">Robotic manufacturing program to launch this fall</a>
						</li>
					<li>
				<a href="http://www.advocate-online.net/news/henderson-garcia-take-gold-forensic-sends-13593/">Henderson, Garcia take gold as Forensic sends it</a>
						</li>
					<li>
				<a href="http://www.advocate-online.net/sports/saints-looking-catch-lane-standings-13589/">Saints looking to catch Lane in the standings</a>
						</li>
				</ul>
		</div>				</div>
				<div class="col-1-3 footer-widget-area">
			<div class="footer-widget footer-2"><h6 class="footer-widget-title">Read the Latest Advocate Issue</h6>			<div class="textwidget"><div data-configid="1545732/48294208" style="width:321px; height:200px;" class="issuuembed"></div><script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script></div>
		</div>		</div>
				<div class="col-1-3 footer-widget-area">
			<div class="footer-widget footer-3"><h6 class="footer-widget-title">Check Out Venture Magazine 2015</h6>			<div class="textwidget"><div data-configid="1545732/36170323" style="width:309px; height:200px;" class="issuuembed"></div><script type="text/javascript" src="//e.issuu.com/embed.js" async="true"></script></div>
		</div>		</div>
	</footer>
<div class="copyright-wrap">
	<p class="copyright">Copyright © 2015 The Advocate</p>
</div>
</div>
				<script type='text/javascript'><!--
			var seriesdropdown = document.getElementById("orgseries_dropdown");
			if (seriesdropdown) {
			 function onSeriesChange() {
					if ( seriesdropdown.options[seriesdropdown.selectedIndex].value != ( 0 || -1 ) ) {
						location.href = "http://www.advocate-online.net/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;
					}
				}
				seriesdropdown.onchange = onSeriesChange;
			}
			--></script>
			
<script type="text/javascript"><!--
wpa2a.targets=[
{title:'Saints looking to catch Lane in the standings',url:'http://www.advocate-online.net/sports/saints-looking-catch-lane-standings-13589/'}];
wpa2a.html_done=true;if(wpa2a.script_ready&&!wpa2a.done)wpa2a.init();wpa2a.script_load();
//--></script>
			<div id="fb-root"></div>
			<script>
				(function(d, s, id){
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.3";
					fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script> <script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/akismet/_inc/form.js?ver=3.1.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.advocate-online.net\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","sending":"Sending ...","cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.1.2'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/youtube-channel/assets/lib/magnific-popup/jquery.magnific-popup.min.js?ver=3.0.7.3'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/youtube-channel/assets/js/youtube-channel.min.js?ver=3.0.7.3'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/comment-reply.min.js?ver=4.6.5'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-content/plugins/easy-twitter-feed-widget/lib/js/widget-easy-twitter-feed-widget.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.advocate-online.net/wp-includes/js/wp-embed.min.js?ver=4.6.5'></script>
</body>
</html>
<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

 Served from: www.advocate-online.net @ 2017-05-07 08:13:26 by W3 Total Cache -->